Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


pte-ernie

P2566 Error Code

4 posts in this topic

 

Hi there Rob. Do you have the Reg number of the car because I work at a Motor Factors and have had a quick look and the fault code seem to be suggesting a Boost Pressure Sensor. We do a Bosch version, Part number 0261230119, at about £100 + Vat.

Would like a Reg to confirm this though,

Thanks, Chris.

Share this post


Link to post
Share on other sites

Hi mate same day you posted this I was suggested the same went to unipart and got the same item. Fitted yesterday (literally the only time I've had) and cleared the error codes only for it to come up with the same p2566 again. Noticed some turbo lag too (although that maybe normal and I've not noticed it before)

Thank you

Rob

Share this post


Link to post
Share on other sites

Any help on this greatly appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now