Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


AaronGall

2004 Ford Fiesta Mk6 - 1.25L Lx

1 post in this topic

Hi all, i was under the panels this morning having a look up at my clutch pedal as its been acting up lately, Found out it was just the clip holding the pedal to the rod was loose, So i clamped it tight with two cable ties until i get it fixed properly.. It has now fixed the problem with the clutch :D.

However when i was doing this i came across a plug that was hanging down right beside my clutch pedal were the pedal meets the rod. It looks like there is something supposed to plugged into it but i have no idea what it is!! All my lights/wipers/radio/windows etc all work perfectly so i have no idea what it is.. Heres a picture to give a better idea, Any help would be appreciated!!

10255351 10202231698088618 2300050495070988596 N

post-53245-0-15783800-1397159698_thumb.j

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now