Jump to content


Photo
- - - - -

Problematic St

ST Heater Squeak

  • Please log in to reply
No replies to this topic

#1 purplehazevr6

purplehazevr6

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Joseph
  • Ford Model: Fiesta ST
  • Year: 2005
  • Location: Wales

Posted 11 April 2014 - 09:25 PM

Hi

Hoping to pick someone's brain as the situation is dreadful with certain aspects of my wife's ST, so have come her hoping for advice please guys.

 

The heater only works when set at #4 regardless of cold or hot selected.

 

The heater only pushes out cold or hot air to the windscreen regardless of where the dial is positioned such as towards the floor.

 

Wow there is a dreadful squeak coming from the rear have tried to diagnose where it is but cant pin point it. Initially thought it was the exhaust rubbers, but have been under and gave it a good shake but nothing.

 

Its much louder and annoying when you start to pick up speed.

 

Also oil warning light comes on periodically the just goes off. But I know there is oil in there as checked the Dip, I suspect a sensor of some sort but looked for a clip on YouTube but nothing.

 

Guys any feedback greatly appreciated as she has my ear-hole bout it all the time...

 

Nice one



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: ST, Heater, Squeak

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users