• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience


sjcrolm

Front End Knocking Noise

Recommended Posts

Morning all, im in need of a littke help.

My 2007 2.0l tdci has developed a rather annoying rattle/knocking.

It seems to be coming frim the front nearside. It seems to happen at odd times, smooth road no noise, slight uneven piece of road, clonk. Pot hole, sometimes gets a noise. So I have tried to narrow it down. Drop link bar replaced, tie rod and end replaced, lower suspension arm with ball joints replaced, strut top bearing replaced!! Seem to be running out of things to replace, anyone else had similar noises? Or shed any light. Any ideas greatfully recieved.

Share this post


Link to post
Share on other sites
 

It definitely sounds as if its coming from the spring area, but checked it when I put the bearing on top of the strut, as for the cv joint, how would this be tested???

Share this post


Link to post
Share on other sites

Go to an open space like a B&Q car park after hours, and drive very slowly in figure 8's, going full lock to full lock. Listen for any knocking sounds as you approach full lock, and check that the steering is smooth throughout the whole steering range.

Share this post


Link to post
Share on other sites

Thanks for help, drop link bars done. Just been out and had another look.

If I get hold of the strut and shake it the rattle seems to come from the spring. I csn syop the rattle by holding it, im wondering if when I replaced the strut bearing, I havent tightened the nut on top of strut enough, it has a really stupid design, and is hard to tighten. I shall try again!! The spring itself was ok, I checked when it was off.

Share this post


Link to post
Share on other sites

Hi. Did you ever fix this issue? I'm having similar problems and practically did the same repairs except for the CV joints. But I want to make sure that's the culprit as this is turning into a money pit, yet the rattles remain.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now