Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


ROOE93

Cigar Lighter

5 posts in this topic

I've had all my fuses checked and he only one hat is blown is a 20 amp sqaure fuse it's not a blade, I've been to halfords and they don't sell them, my mate was looking what it would power and it said in the hand book fuel pump? But my car still runs and the cigar lighter doesn't work? Any ideas?post-51583-139896902402_thumb.jpg

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites
 

fuse location? box number etc...

Share this post


Link to post
Share on other sites

It says it the fuel pump I'll have a look when I get home

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

...I've had all my fuses checked and he only one hat is blown is a 20 amp sqaure fuse it's not a blade, I've been to halfords and they don't sell them, my mate was looking what it would power and it said in the hand book fuel pump? But my car still runs and the cigar lighter doesn't work?

Well, for some vehicles (what vehicle is yours?) the manual is completely hopeless on the fuse locations. I don't know why this should be the case, but it is.

In any case, it doesn't seem to be the fuel pump and it does seem to be the cigar lighter, based on what you have said.

Now, you should also ask yourself whether there is a reason that it has gone. Have you plugged anything unusual into the socket recently? I once had the case where a SatNav was plugged in through a multiway adapter, the connector lost a little chrome finisher ring, and I later found it welded inside the socket.... That took the fuse out and it also got close to melting the wiring, which was undesirable.

Share this post


Link to post
Share on other sites

It's a fiesta 2010 tdci zetec I've replaced the cigar lighter.

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now