• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save


Jaynie91

Fiesta Hazard Lights And Horn Not Working

7 posts in this topic

Hello,

I have a T Reg/1999 Ford Fiesta Mk VI. I needed a new headlight and so we got one from a scrapyard to replace the one I had, which had to be changed due to my partner hitting a pheasant and it broke part of the plastic housing and was held in by 1 screw. We had replaced the passenger one from a scrapyard one before and know how to change one however as we went to replace it, I was checking the lights and the indicator started clicking a lot then suddenly stopped, no indicators, no clicking, no hazards.

We have checked the fuses and the one for the indicators had blown, so we changed it and to begin with had no luck. We then changed the flasher unit on the steering column and seem to have the indicators working but the hazard lights wont work and neither will the horn, which I have the understanding that they work off the same switch.

We have checked the fuses again, all of the ones in the engine and by the steering wheel, we have checked and changed the relays and even tried another hazard light switch from another fiesta but it doesn't seem to work. The horn still works as we have tested this but we don't know what could be causing the hazards to not work. We have also been looking in the Haynes manual and found they are both off the multifunction switch.

Any ideas or help would be great.
Thanks
Jayne

Share this post


Link to post
Share on other sites
 

Sorry, what i meant was we tested the horn in the car by pressing the middle of the steering wheel and it didnt work, however my father in law tested the horn itself under the bonnet and it worked so its not a fault with the horn itself

Share this post


Link to post
Share on other sites

All of these functions are run through relays,

Check the relay box in the engine bay for signs of water getting in,

Dont be alarmed if the wipers start going on while the car is parked or the horn beeping,

Share this post


Link to post
Share on other sites

Sorry for late reply, but thanks as it was the fuse, I can only assume as we checked them before that it blew after we sorted out the indicators.

Thanks

Jayne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now