Jump to content


Photo

Titanium X Business Edition Dab Problem


  • Please log in to reply
51 replies to this topic

#46 paulSp

paulSp

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Paul
  • Ford Model: Modeo Estate
  • Year: 2014
  • Location: Sussex

Posted 13 August 2014 - 05:42 PM

Mine stopped last week and was in the local dealer today for a service.

They have been advised by ford not to fit any more modules as they will stop again.

They were advised today that there will be a software update at the end of the month.

However the DAB is now working after the service, I think they must of disconnected the battery as the electric windows don't go up automatically (just hold the button up to fix that),

maybe that could be a short term fix until the update is available.

 

Paul.



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#47 adambell

adambell

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 251 posts
  • Name: Adam
  • Ford Model: Mondeo Titanium X Business Edition
  • Year: 2014
  • Location: Tyne and Wear

Posted 13 August 2014 - 06:31 PM

I've said it before and I will say it again, a software update will not fix this problem. This is a hardware issue.


Sent from my iPhone using Ford OC mobile app

#48 pagdodd

pagdodd

    Member

  • Budding Enthusiast
  • PipPip
  • 18 posts
  • Name: Paul
  • Ford Model: Mondeo MK4
  • Year: 2014
  • Location: Shropshire

Posted 13 August 2014 - 06:37 PM

So, not been back for a while.
I have had mine in twice now. They fixed it but then it stopped again. So took it back for them to do a hard reset and it has been working solidly for a few weeks now.

Sent from my HTC One using Ford OC mobile app

#49 Drexyl

Drexyl

    Newbie

  • Budding Enthusiast
  • Pip
  • 2 posts
  • Name: Paul
  • Ford Model: mondeo titanium x sport
  • Year: 2013
  • Location: Tyne and Wear

Posted 01 October 2014 - 02:50 PM

Just thought I'd join this exclusive club.

After renewing my mondeo to a titanium x sport 5 months ago my car has developed this seemingly common
Dab radio issue. Everything else on the module works fine except DAB radio. Not a massive problem but one what shouldn't happen nevertheless.
Car is going back to the dealer on Friday morning but I don't hold out much hope.
Will keep people informed as to what the deduce.

Cheers. Paul.

#50 Wotswot

Wotswot

    Newbie

  • Budding Enthusiast
  • Pip
  • 5 posts
  • Name: Peter
  • Ford Model: Mondeo
  • Year: 2013
  • Location: Staffordshire

Posted 03 October 2014 - 07:32 PM

Mine had to go back after the DAB failed again - see previous posts.

The lease company have now agreed to take the car back and replace it due to the many issues with it



#51 pagdodd

pagdodd

    Member

  • Budding Enthusiast
  • PipPip
  • 18 posts
  • Name: Paul
  • Ford Model: Mondeo MK4
  • Year: 2014
  • Location: Shropshire

Posted 03 October 2014 - 07:35 PM

FYI folks. Since the last time mine went in, I have not had any issues with my DAB. So whatever they did, it worked :-)

#52 Drexyl

Drexyl

    Newbie

  • Budding Enthusiast
  • Pip
  • 2 posts
  • Name: Paul
  • Ford Model: mondeo titanium x sport
  • Year: 2013
  • Location: Tyne and Wear

Posted 03 October 2014 - 08:06 PM

Had my car in today about the dab radio issue.
Software update required & all is well now.

Will let everyone know how long it lasts.

Cheers. Paul.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users