• Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


pagdodd

Slight Turbo Lag

6 posts in this topic

My car has done 2000 miles since I had it at the beginning of April.

It's only for a split second but when I put my foot down it seems to lose power before is pulls.

It is most noticeable when cruising between 40 & 70mph

Share this post


Link to post
Share on other sites
 

My colleague had the same with his 62 plate 2.0 TDCi 163 Mondeo. Even took a Ford Tech out and they couldn't understand it.

It is odd as I have the same engine in my Focus and mine doesn't do it, although I did have an ECU update which massively improved response of the engine.

Nothing like that was available for the Mondeo though, so my colleague ended up getting a Bluefin remap and hasn't looked back.

Share this post


Link to post
Share on other sites

Kind of good that it has happened to someone else and I am not just imagining it! :)

Mine is a company car so don't want to spend any money on it. So will try and get Ford to have a look under warranty.

Share this post


Link to post
Share on other sites

Mine 59 plate has it from 70 onwards have been told it is the egr causing but no evidence of a problem anywhere

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Mine 59 plate has it from 70 onwards have been told it is the egr causing but no evidence of a problem anywhere

Sent from my iPhone using Ford OC

I've got the same engine so a remain or tuning box sounds like a wise investment.

Sent from my iPhone using Ford OC mobile app

Share this post


Link to post
Share on other sites

I've tried to removed and clean egr the only problem is the egr will not come off has anyone managed to get an mk4 egr off

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now