Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Jaynie91

Engine Management Light On And Misfiring

8 posts in this topic

My friend has got a Ford KA, 2003, which the engine management light is on and the car is juddering as soon as the engine is turned on.

They have changed the spark plugs and coil pack as per recommendation from a garage however it still has the problem. The HT leads haven't been changed however they are still sparking.

Has anyone else had this problem?

Thanks

Jayne

DELRIO likes this

Share this post


Link to post
Share on other sites
 

did you manage to fix the problem and how ?

DELRIO likes this

Share this post


Link to post
Share on other sites

My streetka 2004 has just started doing exactly this today!

Did u get it sorted jaynie???

Share this post


Link to post
Share on other sites

Just had it on the diagnostic and its a 'cylinder 2 misfire' so just need to source the cause of the misfire. Any input greatly appreciated!

Share this post


Link to post
Share on other sites

i ended up getting the spark plugs, leads and coil pack replaced. it sorted the problem ... for a couple of months and its just started playing up again :/

could be due to the fact that i bought cheap aftermarket parts rather than genuine ford ones?

ford want £100 just for a set of leads whereas the non-genuine ones were only £25.

think im gona try find a set of genuine ones on ebay before i splash out £100 just incase its not actually the leads causing the problem.

input from anyone greatly appreciated :)

Share this post


Link to post
Share on other sites

replaced the coil pack and leads again and it made no difference.

stuck a bottle of redex valve cleaner in the fuel tank and boom she seems to be back to her old self!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now