Jump to content


Photo

Engine Management Light On And Misfiring

KA misfiring engine management light

  • Please log in to reply
7 replies to this topic

#1 Jaynie91

Jaynie91

    Member

  • Budding Enthusiast
  • PipPip
  • 10 posts
  • Name: Jayne
  • Ford Model: Fiesta
  • Year: 1999
  • Location: Cambridgeshire

Posted 10 May 2014 - 01:22 PM

My friend has got a Ford KA, 2003, which the engine management light is on and the car is juddering as soon as the engine is turned on.

 

They have changed the spark plugs and coil pack as per recommendation from a garage however it still has the problem. The HT leads haven't been changed however they are still sparking.

 

Has anyone else had this problem?

 

Thanks

Jayne



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 delboy

delboy

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 427 posts
  • Name: martin
  • Ford Model: c-max ghia 1.8 petrol
  • Year: 2004
  • Location: Somerset

Posted 10 May 2014 - 04:02 PM

go buy yourself a diagnostics tool for about £20 from ebay and it will show you the codes

 

http://www.ebay.co.u...l-/331166274325



#3 delboy

delboy

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 427 posts
  • Name: martin
  • Ford Model: c-max ghia 1.8 petrol
  • Year: 2004
  • Location: Somerset

Posted 17 May 2014 - 08:49 PM

did you manage to fix the problem and how ?



#4 DELRIO

DELRIO

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 42 posts
  • Name: del
  • Ford Model: street ka
  • Year: 2004
  • Location: London

Posted 11 August 2014 - 01:39 PM

My streetka 2004 has just started doing exactly this today!
Did u get it sorted jaynie???

#5 DELRIO

DELRIO

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 42 posts
  • Name: del
  • Ford Model: street ka
  • Year: 2004
  • Location: London

Posted 11 August 2014 - 03:22 PM

Just had it on the diagnostic and its a 'cylinder 2 misfire' so just need to source the cause of the misfire. Any input greatly appreciated!

#6 stephenaxon

stephenaxon

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Location:

Posted 09 October 2014 - 08:05 PM

My car has started doing this on aswell any info?would be handy

#7 DELRIO

DELRIO

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 42 posts
  • Name: del
  • Ford Model: street ka
  • Year: 2004
  • Location: London

Posted 20 October 2014 - 01:51 PM

i ended up getting the spark plugs, leads and coil pack replaced. it sorted the problem ... for a couple of months and its just started playing up again :/

 

could be due to the fact that i bought cheap aftermarket parts rather than genuine ford ones?

 

ford want £100 just for a set of leads whereas the non-genuine ones were only £25.

 

think im gona try find a set of genuine ones on ebay before i splash out £100 just incase its not actually the leads causing the problem.

 

input from anyone greatly appreciated :) 



#8 DELRIO

DELRIO

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 42 posts
  • Name: del
  • Ford Model: street ka
  • Year: 2004
  • Location: London

Posted 01 November 2014 - 11:41 PM

replaced the coil pack and leads again and it made no difference.

stuck a bottle of redex valve cleaner in the fuel tank and boom she seems to be back to her old self!



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users