• Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


Paul1109

Poor Throttle Response / Performance.

7 posts in this topic

Evening all

I have a 59 plate focus 1.8 style (petrol) which I've had for about 3 yrs. Over the time I've had this car I've experienced a number of problems to do with lack of power, such as intermittent flat spots especially after a run on the motorway, stuttering when pulling away (as if not enough gas applied to pedal), cutting out in slow moving traffic. The vehicle has been into fords a number of times but they have been unable to find anything wrong.

2 yrs ago it had a pcm update as vehicle kept cutting out when cold and a new throttle body after i made a fuss over constant lack of performance which did make a difference with only slight hesitation happening from time to time.

However only recently the vehicle has started to cut out when hot in slow moving traffic when after feathering throttle pedal and now when stationary I've noticed that if you rest your foot on throttle pedal and press ever so slightly, revs drop and it starts hunting, take your foot off and it returns to normal idle.

So I'm wondering if this is a fault with the pedal? There's no warning lights on and if it cuts out the vehicle restarts, there isn't any fault codes listed either although I'm going get a scanner so I can see for myself.

I would appreciate any help and advice from anyone who has encountered any similar faults as I'm starting to pull my hair out now and a noticeable bald spot is showing.

Many thanks

Paul.

Share this post


Link to post
Share on other sites
 

There is almost never any simple answer to something like this - consider Ford, even having direct access to the car and the ability to plug diagnostic tools in, anr their resources, training experience etc, still cannot find anything wrong with it -

Som making a diagnosis only from your description, and not have access to plug in a code reader, and not be able to hear, or even smell (can sometimes be important) the car is very difficult

The throttle is now an electronic device, like a computer mouse or the volume on a stereo, it is a variable resistor, or more correctly, a potentiometer, basically it instructs the ECU of what position the throttle is in - the ECU then decides how much fuel to supply etc,

it is possible that the potentiometer can get worn, but unlikely - remember there is no direct connection between the throttle and engine

The engine will have a tendency to have a flatspot in the midrange, (NA petrol) the engine is often based on an earlier design and then emmision control apparatus "stuck"on, and settings for economy, and emmissions (with the detriment of performance, and driveability)

is the car driven very slowly, or at low revs in high gears, ertc, or "redlined" through the gears/ kept in the power?

Share this post


Link to post
Share on other sites

Hi thanks for the reply,

The car isn't driven hard however it isn't driven slowly, it always in the power band as I don't like to labour the engine at low revs. I've been thinking that is the lacking in power down to all this fuel saving tech on the engine or the engine has some sort of adaptive learning and a change in driving style would cause a feeling of lack of performance? If that's the case is there a way of resetting this?

Still think there is a fault with the throttle response though as this cutting out is really baffling and like I wrote on previous post when you press the pedal very very slightly and hold it there the revs drop from about 800 to almost stalling then up to 1200 then repeats until you take your foot off. When your foot is off it returns to 800 (idle).

With a new throttle body being fitted 2 yrs ago whose to say it could be this causing problem, the body inside looks quite clean and doesn't appear to stick which is what's leading me to a faulty signal from the pedal. Have ordered a fault code scanner so hopefully it will shed a bit more light on the matter.

Share this post


Link to post
Share on other sites

i doubt a code reader will help it needs live data to see what the pedal etc is doing and what signals its sending it could be a pedal issue it could be a fuel pump issue a fuel filter issue the 1.8 is still the same engine from 2001 just rebadged and these issues are a pain also theres a hose to the rear of the throttle body that can soften and collapse under acceleration which starves the engine then goes back to normal causing a jump in revs its a u shaped hose coming from the rear of the throttle when accelerating with the bonnet up it will collapse

Share this post


Link to post
Share on other sites

Thanks for your input,

Up to now I've only checked hoses for splits etc but haven't checked if any collapse under acceleration so I'll have a look tomorrow, other than that I've replaced spark plugs, air filter etc etc when I serviced it which again made a slight difference in performance but I must admit I haven't changed the fuel filter as yet so for the sake of a couple of quid I'll try that next and see what happens.

With regard to your comment on looking at live data, clearly I don't have access to fords diagnostic gear but have been reading about a number of apps on the play store that communicate with the car via a Bluetooth obd2 connector, what's the general consensus of opinion on this type of thing and will it read live data to show me what is going on?

Share this post


Link to post
Share on other sites

Hello again,

I know its been a while but I've taken time to look into some of suggestions that some of you guy's have advised me to check and unfortunately have found nothing wrong, no collapsed or ruptured pipework, no vac leaks or air leaks so was back scratching the old noggin until my scanner arrived and when I say scanner I mean a obd2 Bluetooth connector and running the torque app, no dtc's found so looked at throttle percentage gauge which showed at idle 12.9% and with the pedal pressed to the floor it reads 76.9%, now I was under the impression that throttle readings should be 100% with the pedal to the floor and valve wide open. Have checked the valve and butterfly is wide open.

So the million dollar question is, are these values I'm getting correct? To complicate matters further I've found that if you press the pedal slowly, once you get to 2\3 the way to the floor torque gives a reading of 76.9% throttle but then nothing the rest of the way to the floor (it stays at 76.9%). Is this a throttle body fault or a pedal fault OR is this normal??

For good measure I've cleaned the throttle body and lubricated the butterfly spindle and since then the hunting has stopped. So at least that's one problem sorted.

If anyone out there has experienced this or a similar problem am I at a loss as to where to go next and would be very grateful for any ideas.

Sorry for the novel

All the best

Paul.

Share this post


Link to post
Share on other sites

The throttle body opening 100% (or 76.9%) when only 3/4 of the travel is a way for car manufacturers' to give the illusion that the car is more powerful/ more responsive than it really is - this is normal and can be different depending on models - there was even a tuning device similar to a tuning box that connected between the throttle and ECU that could be adjusted for economy/ normal/ performance that brought full thottle on at different pedal amounts

Fuel filter can make a big difference

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now