Jump to content


Photo

Speedo And Fuel Fault


  • Please log in to reply
No replies to this topic

#1 gary12345

gary12345

    Newbie

  • Budding Enthusiast
  • Pip
  • 5 posts
  • Name: gary
  • Ford Model: galaxy
  • Year: 2001
  • Location: Gloucestershire

Posted 14 May 2014 - 05:39 PM

Evening all

I have a ford galaxy 1.9tdi on a 2001

The speedo has stopped working and the fuel gauge goes up and down when driving. Fuel gauge show correct when still For them both to go at the same time I'm looking at a wiring fault

I have read forums with people with the same problem but can't find anything that has fixed the fault

Things that I have done is changed the speedo from a 03 model and the speedo and fuel gauge works fine apart from speedo does not give a true reading as I believe they change the cluster on this year. So I bought another from the same year (2001)and that does the same. Fuel gauge goes up and down and speedo not working. I know the fuel gauge and speedo are not at fault. I have also disconnected the battery for 24hrs. There is no corrosion on the wiring on the 2 blocks that plug into the speedo. Can't under stand how the 03 model speedo works but the earlier model does not

Can anyone shed some light on what the fault could be.
Many thanks in advance


Sent from my iPhone using Ford OC

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users