• Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


Sign in to follow this  
Followers 0
gary12345

Speedo And Fuel Fault

1 post in this topic

Evening all

I have a ford galaxy 1.9tdi on a 2001

The speedo has stopped working and the fuel gauge goes up and down when driving. Fuel gauge show correct when still For them both to go at the same time I'm looking at a wiring fault

I have read forums with people with the same problem but can't find anything that has fixed the fault

Things that I have done is changed the speedo from a 03 model and the speedo and fuel gauge works fine apart from speedo does not give a true reading as I believe they change the cluster on this year. So I bought another from the same year (2001)and that does the same. Fuel gauge goes up and down and speedo not working. I know the fuel gauge and speedo are not at fault. I have also disconnected the battery for 24hrs. There is no corrosion on the wiring on the 2 blocks that plug into the speedo. Can't under stand how the 03 model speedo works but the earlier model does not

Can anyone shed some light on what the fault could be.

Many thanks in advance

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0