Jump to content


Hi - New Member Here


  • Please log in to reply
3 replies to this topic

#1 DaveA



  • New Member
  • Pip
  • 1 posts
  • Name: David
  • Ford Model: Focus Titanium 1.6 TDCi
  • Year: 2013
  • Location: Leicestershire

Posted 14 May 2014 - 09:11 PM

Hi all, just joined the group after 'googling' why the engine fan was still running on my Focus for a few minutes after turning the engine off. Found the answer, many thanks. Just bought 63 Focus Titanium 1.6TDCi and must say I am very impressed with it. I have been driving Mondy's around for the last umpteen years after buying brand new back in the 90's, this is the first Focus I've ever owned. Anyways enough about me, just wanted to say a quick 'Hello'.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,592 posts
  • Name: Bruce
  • Ford Model: KA Edge, BMW 320i Coupe M Sport
  • Year: 2015
  • Location: Essex

Posted 14 May 2014 - 09:14 PM

Hi David, welcome along.

#3 dezwez



  • True Ford Enthusiast
  • PipPipPipPipPip
  • 5,661 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5 petrol
  • Year: 2008
  • Location: Cambridgeshire

Posted 15 May 2014 - 05:29 AM

Hi welcome :)

#4 jeebowhite


    Resident Loon

  • Super Mod
  • 22,303 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent

Posted 15 May 2014 - 08:32 AM

Welcome to the family David, and glad that we were able to help you before you even signed up!

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

Also tagged with one or more of these keywords: Hi

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users