Jump to content


Show
Photo

For Fusion 1.4 Petrol


  • Please log in to reply
3 replies to this topic

#1 jojo2406

jojo2406

    Newbie

  • Budding Enthusiast
  • Pip
  • 4 posts
  • Name: Jo
  • Ford Model: fusion 2
  • Year: 2002
  • Location: Lancashire

Posted 23 May 2014 - 04:00 PM

My car went in for timing belt done last friday and since then it has cut out garage tried everything to fix it. new coil packs new leads sensors but nothing fixed it. It was able to start on tuesday and drive it but hsd to keep revs up otherwise it cut out but now friday it wont start at all and the speedo now doesnt work or the mileage and my radio asking for code. Which I havent got. I have only had the car 3 weeks and at my wits end what could it be and is it easy fix I need the car back on the road asap

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 ljono27

ljono27

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Name: leon
  • Ford Model: fussion2
  • Year: 2004
  • Location: Durham

Posted 23 May 2014 - 08:35 PM

1st of all get a diagnostics done and reprogramme they will give u the code im having similar with my fussion2 my revs sometimes drop low when coasting then cuts out.it sounds like your ecu has forgotten codes ...did u take battery off by anychance?

#3 jojo2406

jojo2406

    Newbie

  • Budding Enthusiast
  • Pip
  • 4 posts
  • Name: Jo
  • Ford Model: fusion 2
  • Year: 2002
  • Location: Lancashire

Posted 25 May 2014 - 01:33 PM

1st of all get a diagnostics done and reprogramme they will give u the code im having similar with my fussion2 my revs sometimes drop low when coasting then cuts out.it sounds like your ecu has forgotten codes ...did u take battery off by anychance?



#4 jojo2406

jojo2406

    Newbie

  • Budding Enthusiast
  • Pip
  • 4 posts
  • Name: Jo
  • Ford Model: fusion 2
  • Year: 2002
  • Location: Lancashire

Posted 25 May 2014 - 01:35 PM

Nope I havent had the battery off but maybe the garage did. Im not sure back to the garage then to see about the ecu. Thanks for your help


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users