• Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


dan2403

Mondeo Mk3 Tdci 2.0L Glow Plugs Limp Mode

Recommended Posts

Hi I am new to this I have a tdci 04 plate 2.0l ford mondeo the car was running all Ok the glow plug started to flash car goes in to limp mode and then cuts out car can be turned off and back on and back to normal

I have plugged car in to code reader and P0251 comes up

I have changed fuel filter

Bought new imv

Done injector leak off test and 10ml in all 4 after 4mins

Cleaned egr valve

Changed pressure sensor on fuel rail

Changed all fuel pipes

Put new turbo and actuator on

Checked all boost pipes for leaks and all Ok

Bought new boost valve

Changed maf sensor

Checked all turbo pipes all Ok

Also made my own fuel tank and made no difference

Also checked fuel pump pressure all Ok

This codes has come up and when plugged in to code reader I clear code and run car and it comes on when I am in 3rd about 3000 revs

Has anyone's else had this problem and fixed it as I am lost at what it could be

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now