Jump to content


Show
Photo

Battery Problem?

battery Focus MK2 engine malfunction new battery?

  • Please log in to reply
1 reply to this topic

#1 RB8

RB8

    Newbie

  • Members via FB
  • Pip
  • 1 posts
  • Name: Rhonda
  • Ford Model: ford focus mk2
  • Year: 2010
  • Location: Other / Non-UK

Posted 07 June 2014 - 04:43 AM

My Focus is about four years old and reg servicing, 70,000 kms on clock. Dead battery..called RACV and got it jumped. They checked battery and alternator and said was fine. Charged battery overnight and was ok for a day or so but certainly not starting as it should. Should I get new battery? A friend reckoned that even though RACV said battery good it may be charging ok but then draining very quickly. It is winter here but not real cold and have never had this problem before... and when I tried to start today no go...accessories come on fine but no engine and then engine malfunction light comes on ... 

would appreciate some responses to this ... Thanks



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 14,765 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 07 June 2014 - 07:38 AM

It sounds to me like your battery is dead. If it discharges completely the cells can become warped. Depending on the temperature outside, its most likely not even fully charging, or is thinking its fully charged when its barely done.

 

Your best bet is going to be to replace the battery with a new silver calcium type and you will most likely find tha it will be fine.




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: battery, Focus MK2, engine malfunction, new battery?

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users