Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


RooBaby

Remote Central Locking - Streetka

7 posts in this topic

Hi all! Just a quick question about the remote central locking on a 2005 StreetKa

It had been awhile since I drove the car so it required a jump start. Since then, every time I unlock the car via the fob, the alarm goes off. It's only a short burst and then switches off. Is this a sign that something isn't right? I.e the battery in the fob is low, or the main battery is low in power and requires replacing?

I've not had to manually open the doors which is what I found my last issue was with the alarm so I know it's not that. Each time I open the doors the alarm goes off longer than the previous time.

What's causing this to happen?

Hope you can help. :) x

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites
 

Sounds like you have water ingress somewhere in the system.

Best thing to do is to to check the fuseboard, fusebox in the engine bay and make sure theres no signs of water ingress. It sounds like the central locking is shorting out the alarm system causing it to blip

Share this post


Link to post
Share on other sites

Stupid question, but is the boot shut? This causes the hazard lights to have a fit if it's not shut correctly.

Share this post


Link to post
Share on other sites

Yeah... Boot is shut.

Cool I'll check the fuse box to see if there's an issue there.

I'm needing the car tomorrow so shall see what it does when I unlock it. Grrr all I've had is problems since I bought the thing :(

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Sadly Roo it sounds like you and I share the same luck in motors, lol.

I am beginning to hope that my misfortunes are passing though, and if my luch can turn (bang head against wood) perhaps yours may too!

Share this post


Link to post
Share on other sites

I hope so! I still have my classic mini to get running too! That is electrical and am not looking forward to locating the fault :(

Alarm on Cosmos (my streetka) had a blip this morning and has behaved the rest of the day. I've had the hood down twice. May have possibly been the hood compartment not being closed properly causing the issue?

I will know for certain when I come to use it again.

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

definately could be!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now