Jump to content


Photo

Engine Management Light - Error P1204

P1204

  • Please log in to reply
1 reply to this topic

#1 Whapter7171

Whapter7171

    Newbie

  • Members via FB
  • Pip
  • 1 posts
  • Name: John
  • Ford Model: Mondeo 1.8 TDCi Ghia
  • Year: 2008
  • Location: Lancashire

Posted 21 June 2014 - 02:34 PM

Hey all

 

The problem: 
 
Today after starting the car after work, the EML came on (amber), car would now rev higher than 1500 rpm and sounded like it was running on 2-3 cylinders. I have had this problem before a few times, all I have had to do is turn off the car and wait a short time and fire it up again, problem then goes away (for a while)
 
Today however, the problem seems to be really bad, it took me 3 attempts to drive about 22 miles. That is the bizarre point, I can inbetween the EML being on, drive quite normal.
 
The car will occasionally jump, the best way I can explain is when a petrol car would misfire and there is a hesitation. Sometimes this happens on acceleration or deceleration.
 
Also now noticed that the traction control light is also on, however now the EML is red no longer amber
 
I spent £30 and called a mobile diagnostic technician. Found the following error codes:
 
P1204 - Injection circuit open/short circuit cylinder 4
General failure information - no sub type information
U0405 - Invalid data received from speed control module
General failure information - no sub type information
 
U0401 - Invalid data received from engine control module/powertrain control module
Algorithm based failure - event information
 
B112B - Steering wheel module
General failure information - mechanical failure
U0010 - Medium speed CAN communication bus
General failure information - no sub type information
U0199 - Lost communication with door control module A
General failure information - no sub type information
U0200 - Lost communication with door control module B
General failure information - no sub type information
 
So he has cleared all the codes for me and suggested I get the P1204 injector issue sorted, may need a new injector and coding or a refurb and coding. Also said I had a networking issue going on somewhere, he suggested I take it to Ford direct as networking issues can be really difficult to troubleshoot.
 
Any ideas what an injector for this car would cost new/refurbed (if possible) and an injector reocde?


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,749 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 21 June 2014 - 06:45 PM

for one injector, you could be looking at £80 - £200 depending on what you get your hands on (recon, through to new). Then coding would be about  £50 - £80.

 

The other issues appear to be wiring related, sounds like you have either a bad harness, possible water ingress, or bad connections on the fuseboard / fuse box etc




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users