Jump to content


Photo

C Max Titanium Radio - Wont Work

ford radio sony DAB

  • Please log in to reply
9 replies to this topic

#1 Caz1982

Caz1982

    Newbie

  • Members via FB
  • Pip
  • 1 posts
  • Name: Carrie
  • Ford Model: C Max Titanium
  • Year: 2011
  • Location: Yorkshire

Posted 26 June 2014 - 12:52 PM

HI There

 

I have just joined the Ford Owners club so hope I am posting this in the correct place

 

I have been a ford owner for over 7 years now and only 3 weeks ago picked up my white C Max Titanium 2011 plate, everything on the car is perfect apart from the radio, it has worked really well up until recently when I put on on to DAB it freezes and it wont let me change stations and jsut says ' no reception'. It will play CDs and it will also bring up the Traffic news but nothing else, I went back to the garage where I purchased it and guess what - he fiddled with some buttons and it started working -  sods law, anyway it worked fine on normal FM until I tried to put it back onto DAB again - guess what it is stuck again and I cant change station - its very bizarre but what could the problem be?

 

Many thanks

 

Carrie



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,420 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 26 June 2014 - 03:22 PM

Sounds like its lost connection with the antenna?

 

Check behind the map light, make sure the connection is solid, then you will have to pull the radio out and see if the antenna is connected securely or otherwise.



#3 khevolution

khevolution

    Settling In Well

  • FOC Supporters
  • 97 posts
  • Name: Kieron
  • Ford Model: Ford C-Max Titanium
  • Year: 2011
  • Location: Sussex

Posted 27 June 2014 - 10:00 AM

i have also just had this problem occur and the irony of it all is it happened after i had taken it to ford to fix another issue

same car also Ford C-max Titanium 2011 plate



#4 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,420 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 27 June 2014 - 01:02 PM

have you checked these connections?



#5 khevolution

khevolution

    Settling In Well

  • FOC Supporters
  • 97 posts
  • Name: Kieron
  • Ford Model: Ford C-Max Titanium
  • Year: 2011
  • Location: Sussex

Posted 27 June 2014 - 03:08 PM

no idea these connections even existed until, i just went and had a look to see to connectors, and a cable running through the middles of them to what i can only assume is the rain sensor.

Tried both re-plugging both connections and its not made any difference.



#6 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,420 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 28 June 2014 - 12:19 AM

was this just on the back of the stereo or under the aerial base?



#7 khevolution

khevolution

    Settling In Well

  • FOC Supporters
  • 97 posts
  • Name: Kieron
  • Ford Model: Ford C-Max Titanium
  • Year: 2011
  • Location: Sussex

Posted 28 June 2014 - 10:31 AM

Just the ariel base, I wouldn't know where to start to get to the back if the radio, car is still under warranty so may just throw the car at ford and let them sort it, but if there is a easy way of doing it then I'm willing to give it a try first

Sent from my Nexus 5 using Ford OC mobile app

#8 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,420 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 28 June 2014 - 03:24 PM

Take it back matey it's easier. If any damage is done by doing it then they pay to fix it lpl

Sent from my MY SAGA C2 using Ford OC mobile app

#9 khevolution

khevolution

    Settling In Well

  • FOC Supporters
  • 97 posts
  • Name: Kieron
  • Ford Model: Ford C-Max Titanium
  • Year: 2011
  • Location: Sussex

Posted 28 June 2014 - 11:19 PM

Yeah my thoughts exactly, I'm paid for the extra warrantee, might as well make good use of it.

Sent from my Nexus 5 using Ford OC mobile app

#10 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,420 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 29 June 2014 - 09:05 AM

Definitely if you had nothing then you have nothing to lose but when they are there to be used I say use them!

Sent from my MY SAGA C2 using Ford OC mobile app

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: ford, radio, sony, DAB

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users