Jump to content


Photo

Starting Problem with the Mondeo


  • Please log in to reply
1 reply to this topic

#1 dobey1954

dobey1954

    Member

  • New Member
  • PipPip
  • 13 posts
  • Ford Model: focus
  • Location:

Posted 06 June 2009 - 05:53 PM

Hi folks
My daughter's Mondeo used to start first turn of the key every time ,but lately it has to been turned over quite a lot to get it started ,then its with a puff of black smoke and a strong smell of petrol,checked the air filter but it was pretty clean ,took the plugs out and replaced them ,checked them again a couple of days later to find them sooted up ,she also says it is using more petrol than it used too, so i guess its something to do with the mixture or something along those lines ,its a 51 plate 2.0 ltr ,thanks in advance for any advice ,Steve

Have something to contribute?

Sign in or register to start a topic...

#2 sr-performance

sr-performance

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 147 posts
  • Ford Model: Ford Escort Van TDDI
  • Year: 2014
  • Location:

Posted 07 June 2009 - 08:51 PM

Hiya mate,
be easier and cheaper in long run to have a diagnostic check done..
could be one of a few things and you might just be wasting money if you dont get it right first time..


steve



www.sr-performance.co.uk


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users