• Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


Sign in to follow this  
Followers 0
dylan

Spooky speedo, hellp

4 posts in this topic

Hi need some hellp with my 1.8. 1999 focus ,

The speedo went to 0 as i was driving , when i took my foot of the acceloratar to stop and pressed the cluch it cut out, it hapend a few times then the needle bounced back up and everything was ok , apart from the other day when it wouldnt start for a few turns of the key. the car has been runing a bit rough lately , so i recently changed oil and filter , plugs,and air filter , got a fuel filter to but couldnt get my fingers around the clips on the old one so thats not done yet

any help would be gratful thanks :blink:

Share this post


Link to post
Share on other sites
 

hi mate - sorry to hear your havin trouble wiv your foci to lol

i have exactly the same car and it happens to me a lot through the winter months mainly but it does it when it feels like it...

up to now i still have no cure for it but i do kno that thats not the only problem you can get - i.e. airbag light coming on / fuel gauge reading empty when u just filled it up along with a few other faults...

i had the ecu remapped by ford a couple of years ago and well it still happens cuttin out and everyfin

so no no help mate just the same situation - i was told that it could be somthing to do with the idle control regulator or sumut like that but i havent had time to have mind cleaned/checked yet

Share this post


Link to post
Share on other sites

Hey, Sorry to hear your both having the same problem. I been having the same problem but after doing some research I came across some info. Apparently the speed control sensor found at the bottom of the gear box is faulty. It's a common fault. My cuz also had the same problem and he changed the control sensor and it seemed to have worked. The sensor doesn't cost much either. Something like £20-30. I still need to get mine done but thought i'd share what i know with y'all. B)

Share this post


Link to post
Share on other sites
Hey, Sorry to hear your both having the same problem. I been having the same problem but after doing some research I came across some info. Apparently the speed control sensor found at the bottom of the gear box is faulty. It's a common fault. My cuz also had the same problem and he changed the control sensor and it seemed to have worked. The sensor doesn't cost much either. Something like £20-30. I still need to get mine done but thought i'd share what i know with y'all. B)

Yes, it is the speed control sensor, £26 inc vat from ford. When it stops working the senor tell the engine management you are not moving, although you are, and it reduces your power, so you end up a bit sluggish, For replacement leave it to your garage, as the car needs to be up in the air, its located at the back of the gearbox. Its a swine to remove as there is a pin that doesnt want to come out...deffo not a roadside repair. My local garage charged me £10 to replace it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0