• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save


Sign in to follow this  
Followers 0
poacher

Mondeo 2.0 diesel

5 posts in this topic

Hi. I have a 54 Mondeo diesel Ghia X. It has just started to hold its revs between 1300. - 1500 as if the cruise control has taken over. The revs reduce on applying the brake or de-clutching, but if not the cars carries on in whatever gear I am in. Once this starts the tick over becomes lumpy at around 900 to 1000. Any ideas folks will be gratefully received.

Share this post


Link to post
Share on other sites
 

Hi. I have a 54 Mondeo diesel Ghia X. It has just started to hold its revs between 1300. - 1500 as if the cruise control has taken over. The revs reduce on applying the brake or de-clutching, but if not the cars carries on in whatever gear I am in. Once this starts the tick over becomes lumpy at around 900 to 1000. Any ideas folks will be gratefully received.

Come on folks somebody must have experienced this problem. No replies I can't believe it.

Share this post


Link to post
Share on other sites

it could be a few things, first check for any air leakes on the hoses, it could be a sticking or s*** up egr valve (these can be taken off and cleaned) an injector problem or even a sensor playing up.are there any codes stored ?

Share this post


Link to post
Share on other sites
it could be a few things, first check for any air leakes on the hoses, it could be a sticking or s*** up egr valve (these can be taken off and cleaned) an injector problem or even a sensor playing up.are there any codes stored ?

Many thanks I will have a look.

Share this post


Link to post
Share on other sites

Hi, may not be of any use to you now. But this is one of the issues i am currently having with my 2004 TDCi, Ford assure me it is an issue relating to the EGR valve needing cleaning/replacing.

Other associated problems are the car 'hunting for revs' at approx 2200rpm when coasting, increased fuel consumption and a lot of black smoke under acceleration. Ive got some spray which worked on my wifes Zafira when i cleaned her EGR valve (the car not the wife), so i'll try that before i replace it.

I got the spray off eBay if anyone is interested. this is the link below:

http://cgi.ebay.co.uk/air-intake-inlet-val...%3A1%7C294%3A50

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0