Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


adam_pryor

2006 Ford Fiesta Freedom Trip Reset

9 posts in this topic

Anyone know why my trip reset on my 2006 ford fiesta freedom isnt working?

The reset switch is on the indicator stalk, if i take the fuse out and replace it the button works once, then nothing???

(it is Not the fuse problem)

Can anyone either link me to a repair or tell me how to repair it please?

Thanks

Share this post


Link to post
Share on other sites
 

have you tired removing the battery for an hour letting everything die out, then put it back on and restart everything ?

Share this post


Link to post
Share on other sites

Yea ive tried that

Sent from my SM-N9005 using Ford OC mobile app

Share this post


Link to post
Share on other sites

My next step is taking the stalk apart (which i want to avoid)

Sent from my SM-N9005 using Ford OC mobile app

Share this post


Link to post
Share on other sites

it could be the stalk on the circuit board not making a connection if its that the speedo unit is pretty easy to take apart and check, you could solder it back together but if not you could it to ford

Share this post


Link to post
Share on other sites

Ok, thanks ill give taking the stalk apart and checking the board inside a go, if not i can replace the stalk? Is ebay a good shot for that part?

Sent from my SM-N9005 using Ford OC mobile app

Share this post


Link to post
Share on other sites

um in not sure you could try and repair the stalk you have if not probs pennies from ford anyway

Share this post


Link to post
Share on other sites

Ok, thanks for the help, ill try to find out how to take them apart and post on here when its sorted :)

Sent from my SM-N9005 using Ford OC mobile app

Share this post


Link to post
Share on other sites

My button also died - I replaced the stalk with one I got for a few quid on ebay.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now