• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


thefish

Fiesta Hazard Switch Help Needed

11 posts in this topic

Can somebody please help before I lose my mind

I have a fiesta 1.4 zetec 0n a 02 plate that has just failed the mot on a few things (nothing major)

but one of those things is Hazard warning tell tale not working correctly. So basically when you turn the hazards on everything works but the switch itself does not flash. So I went to the local breakers an picked up 4 replacement switches just to be sure of getting 1 that worked an guess what non of them would flash either. so far I have checked 5 other makes of cars an non of there hazard switches flash when there hazards are on either

Are the hazard switches supposed to flash on this model?

has anybody else had this problem?

if so how do I fix it?

any help on this would be much appreciated

Thanks in advance

Lee

Share this post


Link to post
Share on other sites
 

Any fuses to try?

Share this post


Link to post
Share on other sites

checked all the fuses behind the glove box an found heated window fuse had blown replaced that but nothing.

When I turn the headlights on the switch lights up as normal with all other dash lights so the little led in there is working

the more I ask about the more I think its not supposed to flash but I really don't know for sure

Share this post


Link to post
Share on other sites

Only other thing that comes up when searching is the hazard relay.

And the green arrows both flash on the instrument panel?

Can the garage who failed it not fix it cheaply?

Share this post


Link to post
Share on other sites

Thanks for your reply matt

the green arrows on the clocks do flash its just the switch doesn't but like I said I don't think its suppose to

but I will look into the relay. I do a bit of work on cars an would like to fix this myself if its broken if not then will have to pay some an don't think it will be cheap

Share this post


Link to post
Share on other sites

This was sent to me as a private message by dan62, must have meant to send to you

Hello, 2002 was a model year change so assuming you have 2002 on the wiring diagram shows the switch only having an illumination LED. Visual indication is from the instrument cluster turn indicator lamps and audible indication from the GEM

Share this post


Link to post
Share on other sites

I took the car to an other mot place today an they agreed with me that the mot place that failed it are wrong and the hazard switch does not flash

thank you so much Matt1981 for your replays an all your help

matt1981 likes this

Share this post


Link to post
Share on other sites

Easy thing to do is take the switch apart and check if there is a bulb in there, it'll just be two clip things holding it together, if it doesn't come apart then there will be no bulb.

Share this post


Link to post
Share on other sites

The only bulb in there is the tiny led that is soldered to the circuit board which you can see as soon as you open up the switch an this led is just to light the switch up at night.

I now also spoke to a ford mot tech who has also said that as long as the green arrows on the clocks flash then it will pass an mot so I will take it back tomorrow an see if I can get my mot

Share this post


Link to post
Share on other sites

Anyone else who sees this and if you own a mk6 fiesta pre face lift or a focus around 99-2004 could I please ask you when you get a spare min or next time your in your car (but not while driving) safety first lol to test your hazard switch to see if it flashes when you turn it on an let me know what you find

thanks in advance Lee

Share this post


Link to post
Share on other sites

A quick update to anybody who my be interested in this topic an to those guys who have help me thanks again.

This was taken from the mot testing and inspection manual vosa

The hazard warning lamp 'tell tale' may be a separate light or the same as the indicator 'tell tale'

However, it must be a flashing light

There you go 100% proof that the guy who failed my mot was wrong on this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now