• Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Luke GTI

Escort Gti 1.8 Missing

46 posts in this topic

U won't unless u get it on a diagnostic machine

Sent from my iPhone

Share this post


Link to post
Share on other sites
 

To tell if your MAF is faulty:

  • Start the car
  • Take note of how it is running
  • Unplug the MAF
  • Again take note of how the car is running.

If the car revs drop considerably or it stalls, the MAF is fine.

If there is no noticeable change, then odds are the MAF is faulty.

Share this post


Link to post
Share on other sites

U will create a fault that way by unplugging it. Then ur engine management light will come on. And have to clear the fault on a machine. Faulty will be maf sensor open circuit

Sent from my iPhone

Share this post


Link to post
Share on other sites

Changed lambda sensor on exhaust and no change ? It worth doing coil pack

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Could try it

Sent from my iPhone

Share this post


Link to post
Share on other sites

U will create a fault that way by unplugging it. Then ur engine management light will come on. And have to clear the fault on a machine. Faulty will be maf sensor open circuit

Sent from my iPhone

Haha no. The Escort is useless. Done it on many and never had a management light come on. Never found a code reader that read it either.

Disconnect the battery for 30mins to reset the system, then try and take it for a test drive. The ECU will re-learn.

Share this post


Link to post
Share on other sites

Does sound like air coming from somewhere. ?

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Check all vacuum pipes and air pipes. Vacuum leak would cause it not to run properly

Sent from my iPhone

Share this post


Link to post
Share on other sites

Checked pipes by spraying wd40 on them to see if car will rev up and nothing . Changed coil pack and ht leads. But under throttle body it wet ?

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

What part of throttle body.

Sent from my iPhone

Share this post


Link to post
Share on other sites

When u open flap and what under it wet

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

If it's fuel it's fine.

Sent from my iPhone

Share this post


Link to post
Share on other sites

N if oil ? Just can't figure it all out lol

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Mite be a tiny bit of oil there. Mite get a bit of oil coming from the inlet manifold. Slightly.

Sent from my iPhone

Share this post


Link to post
Share on other sites

Meaning ?

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

I have seen it on others. normal but. U don't want way to much being there. There are breather pipes. Which will be on the rocker cover check there are not blocked if they are u would get oil being in places it shouldn't be. This kinda of thing is easier if I have the car infront of me lol

Sent from my iPhone

Share this post


Link to post
Share on other sites

Where u from

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Scotland

Sent from my iPhone

Share this post


Link to post
Share on other sites

Where are u from

Sent from my iPhone

Share this post


Link to post
Share on other sites

South east lol

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Lol

Sent from my iPhone

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now