• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear


TomGB

Fiesta 55 P Oil Leak (Newbie)

5 posts in this topic

My Ford Fiesta 2005 1.25 Studio is my first car and I've only had it a few months, I am also not very knowledgeable about cars but am learning.

When I got the car it was fine for about 3 weeks but then I started noticing a fresh oil burning smell mostly after a drive once parked up but also when driving.

My oil levels are fine and there isn't puddles under the car so I assume it's only a minor but annoying leak.

I first looked under the front of the car to discover a patch of oil under the "sump" I think.

Here are some pictures of the discovery:

R5JhG51.jpg

LqzBfTl.jpg

8RsPyQ6.jpg

I removed the air filter box and discovered some oil in locations around the back of the engine.

I then cleaned up all the visible oil I could and waited a day to see if any more would leak. Everywhere seems fine apart from one place which I will show below.

aMv9NJn.jpg

1tgqRLA.jpg

JcJKvix.jpg

Uh77dtE.jpg

QlnVhBc.jpg

4s2HvhN.jpg

I have also included a video to give a better understanding even know my camera skills aren't great.

If you have read this far I thank you as I know this is a long post and look forward to reading any suggestions.

stef123 likes this

Share this post


Link to post
Share on other sites
 

Hello abs welcome Tom!

First of all, the pictures and video are VERY helpful! For a first post and a newbie I think you have nailed if for getting a good response.

Anyway, it looks to me like the valve cover or rocker cover gasket as some know it could be the problem here.

TomGB likes this

Share this post


Link to post
Share on other sites

Hello abs welcome Tom!

First of all, the pictures and video are VERY helpful! For a first post and a newbie I think you have nailed if for getting a good response.

Anyway, it looks to me like the valve cover or rocker cover gasket as some know it could be the problem here.

Thanks for the reply, I will take a look into the rocker cover and am looking forward to any more suggestions. :)

Share this post


Link to post
Share on other sites

Hello abs welcome Tom!

First of all, the pictures and video are VERY helpful! For a first post and a newbie I think you have nailed if for getting a good response.

Anyway, it looks to me like the valve cover or rocker cover gasket as some know it could be the problem here.

It was indeed the rocker cover gasket seal that was leaking, it has been replaced and all seems to be good. Thanks for the help.

stef123 likes this

Share this post


Link to post
Share on other sites

Your welcome,

You can take some of the credit too for the informative post which held enough clues for me to pick out the rocker cover gasket.

Happy motoring once again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now