Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Woodz199

Ford Focus 1.6Tdci 09 Intermittent Loss Of Power

1 post in this topic

Hello - Could I have some help/advice please?

I have a 09 Ford Focus 1.6TDCi which I bought 4 months ago with 66K on the clock, I was driving along the motorway (hour into my journey) and noticed when i went to overtake from 70mph i had no power like normal, felt like i had no turbo and it took ages to get to 80mph. The engine also sounded very loud as it revved up to 3,000rpm. No warning lights, no smoke. This continued until i got off the motorway, turned the ignition off and on immediately and it was fine, all power and back to normal. This lack of power was at low speeds and high speeds in all gears.

Took it to a mechanic who replaced the EGR Valve as it was stuck shut. Drove it again for the first time and this power loss happened 10 minutes into my journey, again no warning signals or smoke just no power from the turbo. Again turned it off then on and it was fine. Spent 250 replacing the value so was pretty annoyed that it had been made worse!!!

Any thoughts on what it could be?

Cheers for any help.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now