• Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Fuse Box Problems

1 post in this topic

Hi i have a galaxy mk2 2.3 petrol having a starting problem at the mo some days it will start and others it needs a booster pack on it, had a meter on it charges around 14v, when trying to start it drops to about 8v. had battery and alternator checked both ar ok doing what there suposed to be doing, did have a new starter fitted nt 6mths ago, what i did notice was the engin e fuse box the second black wire was all burnt could find where this wire go's to and if its the problem the usual alternator wires fine changed tha along with the fuse box over 12 mths ago

would apreciate any ones help on this if pos



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now