Jump to content


Photo

1997 Escort Issues?


  • Please log in to reply
2 replies to this topic

#1 Stu_CDX

Stu_CDX

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: Escort Serenade

Posted 10 April 2008 - 12:07 PM

Hi guys, I'm a new owner. I just bought a Ford Escort Serenade on a P Plate.

It's taken to over heating, crabbing and more. Details Below.

Overheating:

When the vehicle is not being driven at over 30MPH, the engine temperature gets really high. It goes right up to the red section and the fan doesn't come on. There's no mayo on the rad/oil caps and no signs of water loss. The fan doesn't come on at all.

Crabbing:

I don't know what to do here. When steering straight, it feels like its crabbing at like 5-10 degrees to the right. I don't like it!

Front Heated Screen:

Doesn't Work. Period, Switch doesnt light up or nothing.

Hand break:

Again, totally inoperative.

Brakes:

There's a small amount of brake fluid running from the resevoir to on to the master cylinder. They feel ok though...

Headlight flasher/Indicator switch makes the headlights flash whenever you touch it.

Anyone got any info :rolleyes:

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jock0909

jock0909

    Settling In Well

  • New Member
  • PipPipPip
  • 39 posts
  • Ford Model: Focus 1.8 tdci
  • Location:

Posted 10 April 2008 - 12:35 PM

Hi guys, I'm a new owner. I just bought a Ford Escort Serenade on a P Plate.

It's taken to over heating, crabbing and more. Details Below.

Overheating:

When the vehicle is not being driven at over 30MPH, the engine temperature gets really high. It goes right up to the red section and the fan doesn't come on. There's no mayo on the rad/oil caps and no signs of water loss. The fan doesn't come on at all.

Crabbing:

I don't know what to do here. When steering straight, it feels like its crabbing at like 5-10 degrees to the right. I don't like it!

Front Heated Screen:

Doesn't Work. Period, Switch doesnt light up or nothing.

Hand break:

Again, totally inoperative.

Brakes:

There's a small amount of brake fluid running from the resevoir to on to the master cylinder. They feel ok though...

Headlight flasher/Indicator switch makes the headlights flash whenever you touch it.

Anyone got any info :rolleyes:


Overheating -
sounds like the electric fan switch or the fan it's self - I assume you have checked all the hoses and they are all hot and the heater is hot.
Take the plug off the switch and bridge the wires in the plug, If the fan comes on it's the switch or the wiring that's faulty.
If the hoses to the rad are cold then it will be the thermostat.
If the heater and heater hoses are cold - blocked matrix or an airlock.

Crabbing -
Probably suspension failure - broken spring and lots of other possible things.

Are you sure there is a heated front screen fitted?

Handbrake -
is there tension on the handbrake lever when it is applied?

headlight/indicator -
Probably faulty stock - replace it

#3 Stu_CDX

Stu_CDX

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: Escort Serenade

Posted 10 April 2008 - 06:46 PM

Overheating -
sounds like the electric fan switch or the fan it's self - I assume you have checked all the hoses and they are all hot and the heater is hot.
Take the plug off the switch and bridge the wires in the plug, If the fan comes on it's the switch or the wiring that's faulty.
If the hoses to the rad are cold then it will be the thermostat.
If the heater and heater hoses are cold - blocked matrix or an airlock.

Crabbing -
Probably suspension failure - broken spring and lots of other possible things.

Are you sure there is a heated front screen fitted?

Handbrake -
is there tension on the handbrake lever when it is applied?

headlight/indicator -
Probably faulty stock - replace it

Everything gets REALLY hot... That's the problem. I'll check the fan and switch tomorrow morning.

What could have failed in the suspension? A rear wheel bearing is on it's way out as it's humming and stuff...


Yes, it has a front heated screen... There's little lines going through it and the fuse is there and intact.

There is no tension up until the last 3 clicks. I think the cable has broken...

I'll fit a new one tomorrow in regards to the indicator unit.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users