• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


Cruise Control Stopped Working

1 post in this topic

Hi there, name's Andy...new to the forum so big thanks in advance for any advice you may be able to give me.

I have a fiesta titanium 2010 (doesn't have the new sony headstock if that helps?).

Over time, my cruise control buttons have stopped working. I am not 100% certain but it seemed to start roughly around the same time as I started taking my car to a valeter, who uses copious amounts of dash shine on the steering wheel. The buttons were very shiny! Could it be that the dash shine product has got in the switch and is blocking the contacts? The skip buttons on the audio controls also seem to stick on when held to rewind, I'm presuming the faults are linked?

If this could be likely, what are my options before taking it to a service centre? I have some electrical / mechanical skills but don't want to tackle this without knowing what's involved.

Many thanks for taking the time to read this.


ps....I have read the manual and know that the car needs to be travelling somewhere above 18-20mph. :-)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now