Jump to content


Photo

Glow Plug Light Flashing \ Mondeo Tdci Ghia X 02

glow plug mondeo fault broke egr injector

  • Please log in to reply
1 reply to this topic

#1 jayrapbb

jayrapbb

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: j
  • Ford Model: Mondeo ghia x
  • Year: 2001
  • Location: Cheshire

Posted 23 August 2014 - 03:52 PM

Hi, i have a Mondeo estate tdci ghia x 02 2litre and a few months ago the glow plug light began to flash. 

 

The car still drives well but there is a loss of power/speed and does smoke in the morning for a minute or so. 

 

I've blanked the EGR valve off, replaced and bought a new diesel filter, i also replaced a turbo pipe which was originally split. 

 

I also recently put in a second hand injector , however it is in full working order. But this problem still persists no matter what i do with it.

 

any ideas/suggestions will be appreciated!

 

thanks.



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,732 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 01 September 2014 - 03:15 PM

Have you got any error codes at all?




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users