Jump to content


Show
Photo

Chuggs/Losing power


  • Please log in to reply
1 reply to this topic

#1 tvoakes

tvoakes

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: 2.0Ltr LX (1996)
  • Location:

Posted 20 June 2009 - 09:19 PM

Im not really sure how to describe this problem - but here goes.

I have an N reg 1996 Mondeo 2L - When Im driving I notice that the car will sometimes feels like its going to stall - its just chuggs and it feels like its losing power - but literally only for a few seconds - Please bare in mind this happens when the car is in motion - and it could be any speed! There are no changes on the dash - the revs dont drop, the speed doesnt drop etc.

I've tried the simple things - thinking maybe clogged air filter - had that changed and its still doing it. Had my plugs changed and its still doing it.

Again, this happens intermittently, could happen 4 or 5 times a day then not happen for a few days. I'm wondering whether there is something wrong with the air intake or fuel pump etc!

Any idea's - I dont know what else to check?

:blink:

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 gaz6076

gaz6076

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 448 posts
  • Ford Model: Mk5 Fiesta
  • Location: Scotland

Posted 21 June 2009 - 05:21 PM

Try changing the fuel filter. Sounds like either fuel or an air restriction. Check all the pipes under the bonnet and make sure no of them are burst either


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users