Jump to content


Show
Photo
- - - - -

Help! Mk7 S1600 Power Steering Malfunction!?

Mk7 Zetecs Fiesta S1600 Fault Help

  • Please log in to reply
4 replies to this topic

#1 imjamesbtw

imjamesbtw

    Member

  • Budding Enthusiast
  • PipPip
  • 19 posts
  • Name: James
  • Ford Model: Ford Fiesta Zetec S1600
  • Year: 2010
  • Location: Essex

Posted 31 August 2014 - 07:24 AM

Popped to tesco last night, got in the car to drive off, push the ignition start button and the car beeps at me with a message on the dash saying 'steering malfunction, service now'. Then the whole thing goes dead and the ignition won't switch on. It's just out if warranty, done 30k miles, not due for a service for 3k miles. Recovery had to tow me home (so embarrassed), they checked the fuses, battery and no joy!
Anyone had this?? Not a happy bunny!

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 16,086 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 31 August 2014 - 08:20 AM

Sounds like a failed power steering pump but did you get any error codes?

#3 imjamesbtw

imjamesbtw

    Member

  • Budding Enthusiast
  • PipPip
  • 19 posts
  • Name: James
  • Ford Model: Ford Fiesta Zetec S1600
  • Year: 2010
  • Location: Essex

Posted 31 August 2014 - 08:50 AM

Its electric power steering, so i hope its just blown a fuse somewhere!



#4 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 16,086 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 31 August 2014 - 09:41 AM

I know the mondy has 3 fuse boxes think the fez has 2 but can't say for definite. Hopefully it's that or a bad earth somewhere

#5 imjamesbtw

imjamesbtw

    Member

  • Budding Enthusiast
  • PipPip
  • 19 posts
  • Name: James
  • Ford Model: Ford Fiesta Zetec S1600
  • Year: 2010
  • Location: Essex

Posted 31 August 2014 - 12:09 PM

Fingers crossed! Being towed to the dealership tomorrow so I will let you know!!


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users