Jump to content


Photo

My 1.8si revs itself


  • Please log in to reply
3 replies to this topic

#1 ghosthorseman

ghosthorseman

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Escort 1.8si

Posted 27 June 2009 - 05:04 PM

When i drive my mrk7 escort 1.8si in first and second the revs are fine, then i get into third gear and go over (2000rpm) and put the clutch in the revs go up to (3000rpm) by itself and stay ther for around 30 to 40 seconds, could anyone please tell what the problem(s) could be???? and if an engine service could solve the problem bit pricey tho!! :(

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,558 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 28 June 2009 - 08:08 AM

you could try cleaning the idle speed controlle valve and see if this improves the situation.

#3 ukm3evo

ukm3evo

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: Escort Mk6
  • Location:

Posted 12 July 2009 - 08:44 AM

My Son's 1.6 Zetec did this, replaced the EMS temp sender and problem has gone away

#4 bob_series1

bob_series1

    Member

  • New Member
  • PipPip
  • 13 posts
  • Ford Model: Escort RS
  • Location:

Posted 23 July 2009 - 07:03 AM

Does the problem happen when the car is cold or hot.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users