Jump to content


Show
Photo
- - - - -

HELP! Washer Jet Doesnt Work!!


  • Please log in to reply
6 replies to this topic

#1 Nipz

Nipz

    Ford Enthusiast

  • New Member
  • PipPipPipPipPip
  • 1,052 posts
  • Ford Model: Ford Fiesta Zetec MK7
  • Location:

Posted 30 June 2009 - 07:04 PM

Hi,

I noticed today my drivers side washer is broken, well doesnt seam to work. Its just the very right one as your sat in the car.

All the others work perfectly but this one doesnt even push the water out past the bonnet. Ive checked if its blocked and its not and there isnt any water coming out under the bonnet. and because of the covering under the bonnet i cant see if the connect is broke etc.

Any ideas if of what i can do or check before i leave to go to Alton Towers at 4 o clock tomorrow morning? As i would like to be able to clean the windscreen if it gets dirty :P

Thanks in advance :)

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 ZeeJex

ZeeJex

    Settling In Well

  • New Member
  • PipPipPip
  • 86 posts
  • Ford Model: MK7 1.4 Titanium 5dr
  • Location: London

Posted 30 June 2009 - 07:18 PM

You'll be fine to go alton towers tomorrow dont let the thoughts of a dirty windscreen put you off lol. Coming from Plymouth you should miss the rain clouds to the north. If you're that paranoid you could always stick a clean cloth and windscreen spray in your boot :P

#3 Nipz

Nipz

    Ford Enthusiast

  • New Member
  • PipPipPipPipPip
  • 1,052 posts
  • Ford Model: Ford Fiesta Zetec MK7
  • Location:

Posted 30 June 2009 - 07:39 PM

You'll be fine to go alton towers tomorrow dont let the thoughts of a dirty windscreen put you off lol. Coming from Plymouth you should miss the rain clouds to the north. If you're that paranoid you could always stick a clean cloth and windscreen spray in your boot :P


lol thanks! Biggest trip yet so dont want little things annoying me! :D

#4 Flic

Flic

    Area Rep: Southeast 2 (Chrome Hater)

  • New Member
  • PipPipPipPipPip
  • 1,159 posts
  • Ford Model: 09 Fiesta Zetec-S
  • Location:

Posted 30 June 2009 - 07:46 PM

I'm sure you'll be fine, at worse you'll get a bit of dust... or some bird poo, or some jet propelled cow dung, or a swarm of bugs will make a formation and splatter your windscreen... or... OMG I fear I've actually jinxed you now, sorry! Touching wood for you as we speak...

Yes, as I said. you'll be fine :D

#5 ZeeJex

ZeeJex

    Settling In Well

  • New Member
  • PipPipPip
  • 86 posts
  • Ford Model: MK7 1.4 Titanium 5dr
  • Location: London

Posted 30 June 2009 - 08:11 PM

I'm sure you'll be fine, at worse you'll get a bit of dust... or some bird poo, or some jet propelled cow dung, or a swarm of bugs will make a formation and splatter your windscreen... or... OMG I fear I've actually jinxed you now, sorry! Touching wood for you as we speak...

Yes, as I said. you'll be fine :D


lol

#6 Nipz

Nipz

    Ford Enthusiast

  • New Member
  • PipPipPipPipPip
  • 1,052 posts
  • Ford Model: Ford Fiesta Zetec MK7
  • Location:

Posted 30 June 2009 - 08:48 PM

I'm sure you'll be fine, at worse you'll get a bit of dust... or some bird poo, or some jet propelled cow dung, or a swarm of bugs will make a formation and splatter your windscreen... or... OMG I fear I've actually jinxed you now, sorry! Touching wood for you as we speak...

Yes, as I said. you'll be fine :D


lol that was mean!!! :lol:

Looks like its a trip to ford on thursday!

#7 Nipz

Nipz

    Ford Enthusiast

  • New Member
  • PipPipPipPipPip
  • 1,052 posts
  • Ford Model: Ford Fiesta Zetec MK7
  • Location:

Posted 02 July 2009 - 09:12 AM

Well the right one seamed to work randomly again but the other whole on the same dual washer part is now not working!! Must be a block or something.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users