Jump to content


Show
Photo

HELP QUICK!!


  • Please log in to reply
2 replies to this topic

#1 Marko

Marko

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: Ford Mondeo 1.8 TDCi Titanium X
  • Location:

Posted 19 July 2009 - 08:29 AM

Just locked up my Mondeo 57 plate Titanium X.

All of a sudden the alarm starts, lights flashing, the full works.

Alarm has stopped, but hazards are still on, front lights on, radio blaring away to itself, main dash on?!

Remote key fob doesn't work so cant open the doors / boot. The small metal key that comes with the remotes doesn't seem to work.

Anyone got any ideas / know what the problem may be.

If all else fails I'll have to call Green Flag out.

Cheers
Mark

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,463 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 19 July 2009 - 02:25 PM

it sound like its had an electrical meltdown best bet get it back to the dealer and let them sort it while it still under warrenty.

#3 Marko

Marko

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: Ford Mondeo 1.8 TDCi Titanium X
  • Location:

Posted 20 July 2009 - 06:41 PM

Had to get Greenflag out. Good bloke called Dave managed to get in and sorted things out ... swore like a trooper though!

Will be getting it into a Ford garage asap to get them to have a look at it.

Cheers
Mark


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users