• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


Sign in to follow this  
Followers 0
winslet101

Can Anyone Help??

4 posts in this topic

I have a 2001 Mondeo Estate LX 2.0 TD. Great car.

For the last two months however it has developed a terrible knocking/grinding noise coming from the front of the car - mainly drivers side. The sound gets worse when turning especially on a roundabout but the noise is there when driving along a straight road. I can also feel the vibration on the pedals.

It sounds like a problem with the front suspension. A mechanic has replaced the front drivers side coil spring and also both anti- roll bar link arms (both common faulty parts on Fords I am told), but to no avail. Both he and the local Ford dealership have inspected it and are unable to find the cause of the problem, even though they assure me that it is safe! They have looked at all known possibilities but have not found the cause.

Are they missing something?

Any help will be very gladly received. It is driving me mad. It is also taking the whole pleasure out of driving. :(

Share this post


Link to post
Share on other sites
 

Hi,

Have they looked at the CV joint?, also you need to get the coil spring on the other side changed they should be done in pairs its dangerous otherwise.

H

Share this post


Link to post
Share on other sites
Hi,

Have they looked at the CV joint?, also you need to get the coil spring on the other side changed they should be done in pairs its dangerous otherwise.

H

Hi,

I did wonder about the other coil spring but was told it was fine. The spring that was replaced was badly worn and the noise disappeared after it was fitted but soon returned. Will look into the CV Joint.

Thanks for your suggestions.

W

Share this post


Link to post
Share on other sites

I now have a cure at last! The OSF shock absorber started to leak this week and showed itself to be defective. It has been replaced and now I can enjoy driving again!

:rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0