Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
tdci stevie

Mondeo 2.0 TDCi 04 engine idles rough

9 posts in this topic

2004 2.0TDCi 130 55k, having problems with idle it seems like its hunting - getting it jump from 720rpm - 755rpm when idling, its also hesitant when pulling away in any gear its like a 2-3 second pause before you get the power....?

This is me first TDCi so am new to the engine, have just come from a vectra 2.0 DTi.

Also get a rumbling noise when de-ecelerating, changing gears, pulling off in say 2nd/3rd gear.....the noise only stays for about 5 seconds at a time....?

The car had been sat up since April 2009 and i purchased it Saturday 25 July 2009, so its not been run for a good 3 months, nor do i know when it was last serviced, so I gave it a full service yesterday and changing the diesel filter made me flaten the battery trying to start it... so on charge it is...

Any help with these couple of niggly problems would be much epriciated

Share this post


Link to post
Share on other sites
 

2004 2.0TDCi 130 55k, having problems with idle it seems like its hunting - getting it jump from 720rpm - 755rpm when idling, its also hesitant when pulling away in any gear its like a 2-3 second pause before you get the power....?

This is me first TDCi so am new to the engine, have just come from a vectra 2.0 DTi.

Also get a rumbling noise when de-ecelerating, changing gears, pulling off in say 2nd/3rd gear.....the noise only stays for about 5 seconds at a time....?

The car had been sat up since April 2009 and i purchased it Saturday 25 July 2009, so its not been run for a good 3 months, nor do i know when it was last serviced, so I gave it a full service yesterday and changing the diesel filter made me flaten the battery trying to start it... so on charge it is...

Any help with these couple of niggly problems would be much epriciated

after changing the fuel filter you need to actually pre fill the new one it with diesel or it'll never start in a month of sundays. and the rumbling noise could be the accesory drive belt tensioner. ford brought out a T.S.B (Technical Service Bulletin) about them. sorry can't think of any thing for the rough running.

Share this post


Link to post
Share on other sites

Just found out the hard starting after filter change was a dodgy new filter was a cheap pattern part and pipes didnt snug fit over, so off to ford today for original...

Going for M.O.T today hopefully that might shed some light on the nosie thats coming from around the passenger side front

Share this post


Link to post
Share on other sites

Got it M.O.T'd today went straight throungh, engine idles alot better since the full service, but a little bit hunting revs may drop from 760 rpm to 735 rpm roughly....? someone suggested the egr may need cleaning out to improved engine breathing....?

Have got a Sealey diagnostic tool and there is no codes present or pending....?

Any suggestions must appreciated.

Thanks Steve.

Share this post


Link to post
Share on other sites

Clean out the egr valve and the give it a damn good ragging up the motorway to clear it out , they were never the smoothest idlers though.

Share this post


Link to post
Share on other sites

will be cleaning out EGR valve tommorow and put some STP injector cleaner in and give it a good boot hopefully sorts my problem - would the inlet manifold also need taking off and cleaning or could i get away without...?

Does anyone know how hard the auxialry tensior pulley/idler pulley is to change its a bit rattly (heard theres a upgraded/modified one)....?

Share this post


Link to post
Share on other sites

EGR cleaned now performance is much improved still got rattly noise from around engine on idle...?

Share this post


Link to post
Share on other sites

Popped in fords yesterday and they said the engine hunting was down to auxilary belt - tensinoner pulley and crank pulley , he reckons theres a modified one of each belt/tensioner & pulley....?

He said it wasnt that bad and i should put up for it at the minute but its one of those niggly problems.....

Does anyone know if its nessacary to change all 3 parts or could i get away with just belt....?

Share this post


Link to post
Share on other sites

fords tsb 18-2005 for a faulty accessory drive belt recommends replacing all three.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0