• Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience


Sign in to follow this  
Followers 0
Con Rod

Warning light ESP

4 posts in this topic

Hi Folks,

Can any experts out there please comment on my "Ford Direct" Focus estate 4 years old 36,000 miles having the esp light on all the time.

This came on over night just after fourth service, can this fault be created by a dealer as I refused some work that they recommended.

eg front pads 90% worn even though all four pads had a minimum of 3mm of lining!

Error code 1288 and quote for repair approx £1150 for new ABS unit.

Is the whole unit faulty or could it be just a simple fault within?

The dealer who did the diagnostic asked if the car had been flashed?

I think the unit is behind the battery box, are there cheaper units out there and can it be a DIY job?

Really appreciate your time and comments on this issue, hope the ABS still works !!

Many thanks

Share this post


Link to post
Share on other sites
 

The fault cant really be created by a dealer, but if they've had the wheels off during the service (which they should have) they could have disturbed a sensor or damaged something to do with the abs

What engine is it? Can you shed any more light on the error code?

Share this post


Link to post
Share on other sites

Thanks Gaz6076 for your reply,

Engine 1.6 petrol Duratec.

Ford main dealer charged me £86.25 for the diagnostic, the car was back outside in less than half hour !!

Quote from technicians sheet:-

"Investigated into ESP light on placed on IDS & followed guided diag found fault code 1288 brake pressure control, advised new ABS module & valve block".

A few weeks before the light coming on the yaw sensor (near to steering column, I think) was heard clicking far too sensitively, I first thought that this could be the fault if the yaw sensor was faulty?

The car was OK when parked up at night but the light came on immediately on start the next day. ESP switch has no effect.

Fault appeared about 1000 miles after service, also stated dirty brake fluid at service if this means anything? however now replaced.

Cheers for your help, Thanks.

Share this post


Link to post
Share on other sites

I'm not fimillar with the yaw sensor so I couldn't say if the clicking could be the cause. Although the yaw control system would be part of the ESP so you would think a problem with it could put the light on

I'll try find out more on the DTC that ford gave you. I think ford are going for the easy diagnostic there by just replacing the most likley part based on the code and with out doing anything else. You should of got at least an hour for your £86.

I wouldn't pay any attention to the dirty break fluid. Its a ploy to get more money form you. It's recomended you replace it every two years but it's just not necessary (personal opinion)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0