Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
cat

ka problems

4 posts in this topic

Hi all,

i have a W reg 2000 ka done 51k.

The horn seems to have gone, i pressed it last week and it squeaked at me and died! is this it dead completely do you think? Is it expensive to replace?

The wind screen wipers seem to be blocked, bottle full, but no water coming out, have taken the tops off but still no water coming out of the pipes?? the motor does sound like it is working - would it be quiet if it wasn't?

Also loud knocking sound coming from front right when turning right? the wheel does not seem to move when it is on the flat and no handbreak on so not sure if it is a bearing or not? has anyone else had this could it be a joint of some sort?

Need to get all these fixed before MOT in June and just would like an idea of anything i could possibly fix myself cheaper than paying ford to do it!!

All suggestions greatly received! Thanks

Share this post


Link to post
Share on other sites
 

Hi

welcome to FOC

The horn has probably corroded inside or the connections need cleaning. You can pick up a used horn for a few quid from the scrap yard.. most horns will fit. Or halfords do them. As long as it works on the MOT.

The windscreen washer motor may be worn out or you have a kink in the pipe work.

The wheel problem maybe a seized caliper, or sticking brakes. The bearing would make a noise when driving if it was worn.. do you hear a humming noise when driving?

To be honest... a small independent garage would fix this in no time and possible use blue print parts (not genuine parts) so no need to take it to a ford dealer... you'll save bucket loads.

good luck

Steve

Share this post


Link to post
Share on other sites
Hi all,

i have a W reg 2000 ka done 51k.

The horn seems to have gone, i pressed it last week and it squeaked at me and died! is this it dead completely do you think? Is it expensive to replace?

The wind screen wipers seem to be blocked, bottle full, but no water coming out, have taken the tops off but still no water coming out of the pipes?? the motor does sound like it is working - would it be quiet if it wasn't?

Also loud knocking sound coming from front right when turning right? the wheel does not seem to move when it is on the flat and no handbreak on so not sure if it is a bearing or not? has anyone else had this could it be a joint of some sort?

Need to get all these fixed before MOT in June and just would like an idea of anything i could possibly fix myself cheaper than paying ford to do it!!

All suggestions greatly received! Thanks

sounds like the wish bone has gone

quite a simple job to replace

to check it do the following

jack cap up

look under wheel nr the back of the wheel you will see a rubber mount with a bolt through it

see if it's broken as this usually goes

i had same on my galaxy.

cheap part to replace aswell m8

Share this post


Link to post
Share on other sites
sounds like the wish bone has gone

quite a simple job to replace

to check it do the following

jack cap up

look under wheel nr the back of the wheel you will see a rubber mount with a bolt through it

see if it's broken as this usually goes

i had same on my galaxy.

cheap part to replace aswell m8

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0