AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
lms1703

Is my turbo blown

4 posts in this topic

Please can someone help. I have a 02 plate tdci (130) that is not running wright. When I put it under load I can hear a whooshing noise thats gets louder the more I put it under load. I also have a loss of power but it will still travel at motorway speeds but it takes abit longer to get there. I have no lights on the dash. I have a bit have black smoke no grey. I have checked the fin inside the turbo and it turns fine and it does not move side to side. Thanks in advance.

Share this post


Link to post
Share on other sites
 

Please can someone help. I have a 02 plate tdci (130) that is not running wright. When I put it under load I can hear a whooshing noise thats gets louder the more I put it under load. I also have a loss of power but it will still travel at motorway speeds but it takes abit longer to get there. I have no lights on the dash. I have a bit have black smoke no grey. I have checked the fin inside the turbo and it turns fine and it does not move side to side. Thanks in advance.

hello mate have a check of the pipe that goes from the egr valve to the intercooler, it is at the front of the engine, to the right and is about 2" diameter, they are prone to splitting. hope that helps dave

Share this post


Link to post
Share on other sites

as Dave says, 90% sure it will be the inter cooler pipe that has split, you may have to remove it to check it fully.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0