• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


Sign in to follow this  
Followers 0
Kev

Accelerator Problem

1 post in this topic

Hi,

I have a ford fiesta at the moment, which is a Mk4 (R plate). Latly When i change gear when i De-Clutch in order to change gear, the accelerator seems to stay revving, therefore i get high revs when i de-clutch. It is like the accelerator is jammed down. This also means that when i take my foot off the gas whilst in gear i get no engine breaking, and if anything i have at times even speeded up. Does anyone know why this is doing this. I have also tested it by simply turning the car on and revving it in nuteral, the accelrator dosnt jam down, it only happens when i am actually driving. I have put Plenty of WD40 on both the showing parts of the cable from the pedal to the engine...

help?

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0