Jump to content


Photo

My Ka keeps stalling ???????????????? Help please


  • Please log in to reply
3 replies to this topic

#1 no1villaman

no1villaman

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Ka
  • Location:

Posted 20 May 2008 - 09:08 AM

New to all this so Hi to all.

"R" reg Ka. 1.4, Starts fine and sits at idle ok.
However when driving if I pull up at a juction etc or let the engine drop to idle it will stall.

Also when stationary if i rev the engine it will fall to idle and stall.

I have changed the plugs and leads and it made no difference.

Any clues ?????????????????????

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 hotashel

hotashel

    Settling In Well

  • New Member
  • PipPipPip
  • 79 posts
  • Ford Model: mark 4 escort xr3i cabaret
  • Location:

Posted 20 May 2008 - 06:04 PM

Hi,

Could be the idle control valve.

#3 no1villaman

no1villaman

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Ka
  • Location:

Posted 25 May 2008 - 03:28 PM

Hi,

Could be the idle control valve.

Spot on, thanks.......
Tried cleaning it but still no better.......
100 for the valve but Ka is running like a dream now.

Thanks again :rolleyes:

#4 hotashel

hotashel

    Settling In Well

  • New Member
  • PipPipPip
  • 79 posts
  • Ford Model: mark 4 escort xr3i cabaret
  • Location:

Posted 25 May 2008 - 05:17 PM

Hi,

Glad its fixed.

H


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users