Jump to content


Show
Photo

digital aircon controls help


  • Please log in to reply
4 replies to this topic

#1 tony1210

tony1210

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: 1.8 tdci
  • Location:

Posted 20 May 2008 - 06:06 PM

hi hope someone can help and maybe save me some money, i have a 03 1.8tdci ghia, i seem to have a intermitent fault with my digital heater control, sometimes when i use the car the digital controls dont work, the display is blank and the buttons do nothing, but the heater fan is blowing on full , with no way of turning it down or off , the next time i use the car everything is fine? its seems pot luck if it works or not. ive checked the fuses and fiddled with the relays but still got the problem , could i be looking at a new aircon heater digital display unit? or am i missing something obvious? ive had the unit out but could find no loose wires or loose connections. i would be gratefull for any help or advice....thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Steve

Steve

    Administrator

  • Admin
  • 4,924 posts
  • Ford Model: Kugy
  • Location: Dorset
Contributor

Posted 22 May 2008 - 07:17 PM

sounds like the circuit board is faulty..could be a dry joint... if you have to replace it then i suggest taking it out then trying to open up where the connections are and giving a a good going over with a contact cleaner from Maplins.

May i ask does the weather affect it? when its hot it works or vice versa?

#3 tony1210

tony1210

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: 1.8 tdci
  • Location:

Posted 23 May 2008 - 03:52 PM

sounds like the circuit board is faulty..could be a dry joint... if you have to replace it then i suggest taking it out then trying to open up where the connections are and giving a a good going over with a contact cleaner from Maplins.

May i ask does the weather affect it? when its hot it works or vice versa?

no the weathers not affecting it , it seems to have a mind of its own, when it works it stays on , even over bumps ,but when i turn the engine off and come back to start the car the blowers are on full but the ac control unit is dead even the heated screen buttons do nothing, i have bought a secondhand unit of ebay hopefully this will cure it or ive just wasted forty quid, fingers crossed

#4 tony1210

tony1210

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: 1.8 tdci
  • Location:

Posted 31 May 2008 - 04:03 PM

success fitted air con control unit of ebay and now everything is working as it should

#5 Steve

Steve

    Administrator

  • Admin
  • 4,924 posts
  • Ford Model: Kugy
  • Location: Dorset
Contributor

Posted 31 May 2008 - 10:40 PM

nice one tony.. glad to see you have it sorted.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users