Jump to content


1998 Escort 1.6 CL Estate, just bought, couple of little problems

  • Please log in to reply
4 replies to this topic

#1 The Badger

The Badger


  • New Member
  • PipPip
  • 11 posts
  • Ford Model: Escort Estate 1.6 CL
  • Location:

Posted 30 September 2009 - 02:44 PM

Hi all

Just purchased the above and I have a couple of little problems, first being:

Drivers side electric window doesn't work, I haven't tried anything yet but will try the obvious things first, fuse, switch etc. is there anything else I should try or are there any known faults with wiring etc. on this model?

The engine seems to hesitate every so often, feels like your in fifth doing 15 MPH and you put your foot down, this is only happening maybe 6 or 7 times on a 30 mile journey and only seems to do it once warm.

It didn't come with a load cover, does this model come with one and if it doesn't is it possible to fit one and what components will I need other than the load cover?

It needs a new wing, O/S/F, are these still easy to replace or would it be advisable to take it to a bodyshop?

Right guys think that's it for now, any advice would be greatly appreciated.


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 vinnyvangough


    Ford Enthusiast

  • Moderator
  • 2,329 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 01 October 2009 - 12:37 PM

Hey bud,

Welcome to the club,

The window,
As you said, check the fuse, and the switch but the motors are known to get tired and stop.

Engine hesitation
Could be the idle control valve (ICV) needs taking off and cleaning and replacing

New wing
These are spot welded on, all i would do is remove the front bumper, drill out the spot welds, around 12 of them, undo the 2 bolts in by the door, and replace with a new wing, fixing it in with a small amount of silicone and some rivets.

Hope this helps

#3 Stu Sly

Stu Sly


  • New Member
  • Pip
  • 5 posts
  • Ford Model: Escort 1.8 Si Estate
  • Location:

Posted 01 October 2009 - 04:16 PM

Yeah could be the ISCV

also might be work checking the Air flow sensor (MAF).

or the Air temp sensor...

#4 The Badger

The Badger


  • New Member
  • PipPip
  • 11 posts
  • Ford Model: Escort Estate 1.6 CL
  • Location:

Posted 02 October 2009 - 03:01 PM

Thanks for the replies guys, I shall try everything as prescribed!!!

Also I forgot to say in my first post that the clutch biting point is very high and very small, i'd say the last 3 to 4 cm is biting, I now on older fords they had a plastic ratchet that tended to break, is it the same on the newer fords or could it be a completely different problem?

Thanks once again for the replies

#5 petrol-head



  • New Member
  • Pip
  • 6 posts
  • Ford Model: escort
  • Location:

Posted 08 October 2009 - 04:10 PM


Just reading your post there i had the same problem with my drivers window in my 98 escort hathcback.

i jus took the casein round my switches for the windows and gears off pulled the drivers window switch and disconected the wires.

when i done this i noticed one of the metal clips in the drivers switch was bent and obviously not touching the other clip to make a full circuit so i slightly bent it till it was straight put the wires back in and my window has worked since.

hope this helps you somewhat with your window!

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users