Jump to content


2.0 TDCi intermitent starting problem

  • Please log in to reply
1 reply to this topic

#1 dowts



  • New Member
  • Pip
  • 3 posts
  • Ford Model: Mondeo Zetec S - 2.0 TDCi 130hp
  • Location:

Posted 13 October 2009 - 10:24 AM

Hi, have a 52 plate Mondeo TDci zetec S.

Initial problem started when I was driving along and conked out. No engine management light. Checked all belts were on; they were. Tried to start it; starter motor turning over and also engine but not firing up. Repeatedly tried to start until battery flat.

Called AA, turned up and although he had to provide charge to battery (because I flattened it by starting it), he started it up first time. He plugged in diagnostics and found fault pointing at main relay, although this was probably due to me running battery flat. Anyway, he followed me back to my house and car running no problem, it'd even stop and start up.

About an hour later, went to start it up, same problem, not starting.. half hour after that, it would... and now it won't (i think you get the point now!)

I've tried swapping around fuel pump relay with other relays to see if the fault would transfer with it: outcome no change. Changed over ECU supply relay with another; outcome no change. Checked associated fuses for ECU and fuel pump; outcome all ok.

The thing that confuses me though is that all the while there is NO ENGINE MANAGEMENT LIGHT appearing which I would expect to show with an unexpected pressure drop on the fuel rail or other ECU problem... which is leading me to suspect it's something basic....

Anyone had this problem before? i think i'm exhausting ideas but am reluctant to have an expensive trip to the garage!

Thanks for looking, Mark

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 paul220



  • New Member
  • Pip
  • 4 posts
  • Ford Model: mondeo mk3

Posted 13 October 2009 - 05:57 PM

got same sort of problem .....diagnostics said "main relay malfunction".......dunno what one it is but still confused

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users