Jump to content


Photo

Escort 1.8 TD (R)


  • Please log in to reply
2 replies to this topic

#1 tonic2k

tonic2k

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: escort 98 (R) TD 1.8
  • Location:

Posted 03 November 2009 - 10:31 PM

ive been looking on a few forums now and although ive found this problem a few times there has never been a solution,

basicly the engine will run fine then all of a sudden it will bellow out blue smoke but its not burning oil the smoke smells like someone has just lit a bbq, when normal driving it will be fine, then just run lump with blue smoke and no power

i have done the following

1) replaced air filter
2) replaced fuel filter
3) replaced glow plugs
4) replaced a fuel line that had perished

i am now stuck for what to tackle next any help would be great

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 06 November 2009 - 10:01 AM

How often does it do this?

IE, every few seconds? few minutes? every hour etc

#3 tonic2k

tonic2k

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: escort 98 (R) TD 1.8
  • Location:

Posted 06 November 2009 - 07:28 PM

How often does it do this?

IE, every few seconds? few minutes? every hour etc


its very random will do it for an hour then be fine for a day then be crap for a week then ok for 3 days its all over the place, its started doing it nearly all the tme now tho


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users