• Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


Sign in to follow this  
Followers 0
MadMalx

Diagnostics on P0420 code

1 post in this topic

The engine management light has been coming on for a while now on my 2003 Focus (1.6 Zetec SE engine), and after a bit of searching the internet I have found this could be either the lambda sensors or the cat. I used my diagnostics software on the car and found that once the engine had gone into 'closed loop', the pre-cat lambda was switching but the post-cat was giving a steady reading. Problem is that after a few days, when the light had come on again, I re-did this test and found both the pre and post cat sensors were switching with a very similar pattern, indicating a failed cat. Am I right in assuming that the cat might be borderline failing hence giving me the different results?

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0