Jump to content


Show
Photo

V reg 2.0i Ghia just stops among other things


  • Please log in to reply
1 reply to this topic

#1 teddyman

teddyman

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: 2.oi Ghia
  • Location:

Posted 09 November 2009 - 04:38 PM

I have a Focus 2.0i Ghia from 1999 with 125000 on the clock. The problem is is has spates of just stopping at times when slowing down, it just cuts out but so far it will start again immediately.Also other intermittent problems - the speedo stops working for a while,digital mileometer goes to just dashes,esp light on dash comes on.
All these things can happen all at once or individually,many times in say 30 mins or not at all for several days.
Any thoughts out there?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 4,324 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 09 November 2009 - 06:41 PM

I have a Focus 2.0i Ghia from 1999 with 125000 on the clock. The problem is is has spates of just stopping at times when slowing down, it just cuts out but so far it will start again immediately.Also other intermittent problems - the speedo stops working for a while,digital mileometer goes to just dashes,esp light on dash comes on.
All these things can happen all at once or individually,many times in say 30 mins or not at all for several days.
Any thoughts out there?

sounds like your speedo clocks are going
happened a lot on the early ones :(


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users