Jump to content


Photo

CAT and ECU


  • Please log in to reply
1 reply to this topic

#1 sweep05

sweep05

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: streetka
  • Location:

Posted 11 June 2008 - 04:40 PM

My ECU light had been on a few weeks and I took it to garage this week to be checked and for MOT. The garage have told me my CAT and sensors have failed and need replacing (for a huge cost). However, they said the emissions are fine and passed the MOT and there are no symptons/problems. Do you think they are right or could the sensor just be gone? Can the ECU tell the difference? Do I ned to replace it if there are no problems? Also, any idea where I can get one - I've tried cats4less etc but it seems to be dealer only.

Have something to contribute?

Sign in or register to start a topic...

#2 ARH

ARH

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Ka
  • Location:

Posted 27 June 2008 - 11:27 AM

My ECU light had been on a few weeks and I took it to garage this week to be checked and for MOT. The garage have told me my CAT and sensors have failed and need replacing (for a huge cost). However, they said the emissions are fine and passed the MOT and there are no symptons/problems. Do you think they are right or could the sensor just be gone? Can the ECU tell the difference? Do I ned to replace it if there are no problems? Also, any idea where I can get one - I've tried cats4less etc but it seems to be dealer only.


Hi new to Ka, but I can give you a generic answer.
Ecu can only read the emmission before and after the CAT and make judgement on that info.
If MOT emissions are ok then the ecu has been given dud info ie the rear oxy sensor seems faulty.
A.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users